Author Topic: FIMK 0.4.0 - Everybody update please  (Read 7391 times)

Dirk Diggler #15 on: March 23, 2015, 02:41:45 PM

  • FIMK Staff
  • *****
  • Posts: 486
    • View Profile
    • Krypto Fin ry
Hmm BTW a different question. If i'm leasing account to forging pool which didn't update server to newest version yet is that affecting in any way leasing results or does blocks are forged there as usually?

As long as the forging pool updates to 0.4.0 before the fork happens you should be ok. Otherwise you might miss out on some blocks until the pool updates to the new 0.4.0 fork.

We're currently working on better leasing UI.
FIMK Developer | GPG fingerprint: CEF2 7C39 43BE 6800 504E  71BC 7E87 A7B0 AC34 E2D5 | mofowallet.com | blog

abctc #16 on: March 23, 2015, 06:12:38 PM

  • Fresh Fimker
  • *
  • Posts: 44
    • View Profile
when I run this on a VPS, I can access it through an ssh tunnel, but my account is empty?

It shows the same account as on the desktop version but it is empty.

- yes, I have similar problem.
MOFO shows zero balance when I access my VPS with https as usual (it worked with 0.2 - 0.3.3):  https://<VPS's IP>:7886

of course nxt.apiSSL=true in the properties, as well as nxt.websocketSSL=true

farcurlew #17 on: March 23, 2015, 09:11:46 PM

  • Fresh Fimker
  • *
  • Posts: 15
    • View Profile
- yes, I have similar problem.
MOFO shows zero balance when I access my VPS with https as usual (it worked with 0.2 - 0.3.3):  https://<VPS's IP>:7886

of course nxt.apiSSL=true in the properties, as well as nxt.websocketSSL=true

It really sucks. Now we cannot forge.
« Last Edit: March 23, 2015, 09:21:39 PM by farcurlew »

Dirk Diggler #18 on: March 23, 2015, 09:24:03 PM

  • FIMK Staff
  • *****
  • Posts: 486
    • View Profile
    • Krypto Fin ry
It really sucks. Now we cannot forge.

We are working on an update.

Untill that you could always use the command line it's not difficult.

In nxt.properties (or nxt-default.properties set nxt.enableAPIServer=true)

Then in your browser type http://localhost:7886/nxt?requestType=startForging&secretPhrase=PUT-YOUR-SECRET-PHRASE-HERE and hit enter.
FIMK Developer | GPG fingerprint: CEF2 7C39 43BE 6800 504E  71BC 7E87 A7B0 AC34 E2D5 | mofowallet.com | blog

farcurlew #19 on: March 23, 2015, 09:24:47 PM

  • Fresh Fimker
  • *
  • Posts: 15
    • View Profile

Dirk Diggler #20 on: March 23, 2015, 09:29:23 PM

  • FIMK Staff
  • *****
  • Posts: 486
    • View Profile
    • Krypto Fin ry
We are working on an update.

Untill that you could always use the command line it's not difficult.

In nxt.properties (or nxt-default.properties set nxt.enableAPIServer=true)

Then in your browser type http://localhost:7886/nxt?requestType=startForging&secretPhrase=PUT-YOUR-SECRET-PHRASE-HERE and hit enter.

Oops, forgot to add apiServerEnforcePOST ...  :P

So in nxt.properties or nxt-default.properties you need to set

nxt.apiServerEnforcePOST=false
nxt.enableAPIServer=true

Then you can enter http://localhost:7886/nxt?requestType=startForging&secretPhrase=PUT-YOUR-SECRET-PHRASE-HERE in your browser.
Of course if your server is not on localhost but on another server you would use that server IP instead of localhost.

But better is if you log in over SSH and use WGET or CURL on the command line.
FIMK Developer | GPG fingerprint: CEF2 7C39 43BE 6800 504E  71BC 7E87 A7B0 AC34 E2D5 | mofowallet.com | blog

kani #21 on: March 24, 2015, 12:16:38 AM

  • Senior Fimker
  • ***
  • Posts: 154
    • View Profile
We are working on an update.

Untill that you could always use the command line it's not difficult.

In nxt.properties (or nxt-default.properties set nxt.enableAPIServer=true)

Then in your browser type http://localhost:7886/nxt?requestType=startForging&secretPhrase=PUT-YOUR-SECRET-PHRASE-HERE and hit enter.

How to create an encrypted command line script using curl and gpg:
http://forum.fimk.fi/index.php?topic=316.msg963#msg963

BitShares - Your share in the Decentralized Exchange

ylo #22 on: March 24, 2015, 07:32:28 AM

  • Fresh Fimker
  • *
  • Posts: 10
    • View Profile
Still no forging going on with the server... I did the conf changes described aboeve, i.e. enable APIserver and disable enforcePOST, but no luck.

server starts up normally(?):
Code: [Select]
Initializing FIM server version 0.4.0 (based on NXT 1.4.13)
2015-03-24 08:18:30 INFO: logging enabled
2015-03-24 08:18:30 FINE: java.version = 1.7.0_75
2015-03-24 08:18:30 FINE: java.vm.version = 24.75-b04
2015-03-24 08:18:30 FINE: java.vm.name = OpenJDK Server VM
2015-03-24 08:18:30 FINE: java.vendor = Oracle Corporation
2015-03-24 08:18:30 FINE: java.vm.vendor = Oracle Corporation
2015-03-24 08:18:30 FINE: java.home = /usr/lib/jvm/java-7-openjdk-i386/jre
2015-03-24 08:18:30 FINE: java.library.path = /usr/java/packages/lib/i386:/usr/lib/i386-linux-gnu/jni:/lib/i386-linux-gnu:/usr/lib/i386-linux-gnu:/usr/lib/jni:/lib:/usr/lib
2015-03-24 08:18:30 FINE: java.class.path = fim.jar:lib/jetty-continuation-9.2.9.v20150224.jar:lib/jetty-io-9.2.2.v20140723.jar:lib/h2-1.3.176.jar:lib/jetty-server-9.2.9.v20150224.jar:lib/jetty-http-9.2.2.v20140723.jar:lib/websocket-server-9.2.9.v20150224.jar:lib/lucene-core-3.6.2.jar:lib/bcprov-jdk15on-151.jar:lib/jetty-security-9.2.9.v20150224.jar:lib/slf4j-api-1.7.7.jar:lib/websocket-common-9.2.9.v20150224.jar:lib/jetty-util-9.2.9.v20150224.jar:lib/slf4j-jdk14-1.7.7.jar:lib/jetty-io-9.2.9.v20150224.jar:lib/jetty-continuation-9.2.2.v20140723.jar:lib/jetty-servlets-9.2.9.v20150224.jar:lib/jetty-servlets-9.2.2.v20140723.jar:lib/jetty-servlet-9.2.9.v20150224.jar:lib/json-simple-1.1.1.jar:lib/servlet-api-3.1.jar:lib/jetty-server-9.2.2.v20140723.jar:lib/jetty-util-9.2.2.v20140723.jar:lib/jetty-http-9.2.9.v20150224.jar:lib/websocket-api-9.2.9.v20150224.jar:lib/jetty-security-9.2.2.v20140723.jar:lib/jetty-servlet-9.2.2.v20140723.jar:lib/websocket-servlet-9.2.9.v20150224.jar:conf
2015-03-24 08:18:30 FINE: os.arch = i386
2015-03-24 08:18:30 FINE: sun.arch.data.model = 32
2015-03-24 08:18:30 FINE: os.name = Linux
2015-03-24 08:18:30 FINE: file.encoding = UTF-8
2015-03-24 08:18:30 FINE: availableProcessors = 2
2015-03-24 08:18:30 FINE: maxMemory = 477364224
2015-03-24 08:18:30 FINE: Database jdbc url set to: jdbc:h2:fim_db/fim;DB_CLOSE_ON_EXIT=FALSE;MVCC=TRUE;CACHE_SIZE=166912
2015-03-24 08:18:32 FINE: Database connection pool current size: 1
2015-03-24 08:18:32 INFO: Database update may take a while if needed, current db version 250...
2015-03-24 08:18:32 FINE: My peer info:
{"shareAddress":true,"platform":"PC","application":"FIMK","nxtversion":"1.4.13","version":"0.4.0"}
2015-03-24 08:18:32 INFO: User interface server not enabled
2015-03-24 08:18:32 FINE: Begin building asset price chart table
2015-03-24 08:18:32 FINE: Database connection pool current size: 2
2015-03-24 08:18:32 FINE: Database connection pool current size: 3
2015-03-24 08:18:32 FINE: Done building asset price chart table
2015-03-24 08:18:32 FINE: Running 2 tasks...
2015-03-24 08:18:32 FINE: Loading known peers from the database...
2015-03-24 08:18:33 INFO: Genesis block already in database
2015-03-24 08:18:33 INFO: Last block height: 440328
2015-03-24 08:18:33 FINE: Running 3 final tasks...
2015-03-24 08:18:33 INFO: Started API server at 127.0.0.1:7886
2015-03-24 08:18:33 INFO: Started WebSocket server at 127.0.0.1:7986
2015-03-24 08:18:33 INFO: Started peer networking server at 0.0.0.0:7884
2015-03-24 08:18:33 FINE: Starting 8 background jobs
2015-03-24 08:18:33 FINE: Starting 2 delayed tasks
2015-03-24 08:18:33 INFO: Initialization took 2 seconds
2015-03-24 08:18:33 INFO: FIM server 0.4.0 (based on NXT 1.4.13) started successfully.
2015-03-24 08:18:33 FINE: Known peers: 34

I don't get any response with my wget:
Code: [Select]
--2015-03-24 08:24:19--  (try: 3)  http://localhost:7886/nxt?requestType=startForging
Connecting to localhost (localhost)|127.0.0.1|:7886... connected.
HTTP request sent, awaiting response... No data received.
Retrying.

-y

Dirk Diggler #23 on: March 24, 2015, 09:49:33 AM

  • FIMK Staff
  • *****
  • Posts: 486
    • View Profile
    • Krypto Fin ry
Still no forging going on with the server... I did the conf changes described aboeve, i.e. enable APIserver and disable enforcePOST, but no luck.
2015-03-24 08:18:33 INFO: Started API server at 127.0.0.1:7886
[/code]

I don't get any response with my wget:
Code: [Select]
--2015-03-24 08:24:19--  (try: 3)  http://localhost:7886/nxt?requestType=startForging
Connecting to localhost (localhost)|127.0.0.1|:7886... connected.
HTTP request sent, awaiting response... No data received.
Retrying.

In nxt.properties put:

nxt.apiServerEnforcePOST=false
nxt.enableAPIServer=true

Then try http://127.0.0.1:7886/nxt?requestType=startForging&secretPhrase=PUT-YOUR-SECRET-PHRASE-HERE

FIMK Developer | GPG fingerprint: CEF2 7C39 43BE 6800 504E  71BC 7E87 A7B0 AC34 E2D5 | mofowallet.com | blog

ylo #24 on: March 24, 2015, 01:36:54 PM

  • Fresh Fimker
  • *
  • Posts: 10
    • View Profile
As said in the post:
Quote
I did the conf changes described above, i.e. enable APIserver and disable enforcePOST, but no luck.

and checked the config and restarted couple of times....

-y

In nxt.properties put:

nxt.apiServerEnforcePOST=false
nxt.enableAPIServer=true

Then try http://127.0.0.1:7886/nxt?requestType=startForging&secretPhrase=PUT-YOUR-SECRET-PHRASE-HERE

Espo #25 on: March 26, 2015, 10:23:05 AM

  • Fresh Fimker
  • *
  • Posts: 16
    • View Profile
Is it a normal, that about all 5 minutes is a rollback?
I'm forging with a VPS Ubuntu.

Thank you :)

Zlotnik #26 on: March 28, 2015, 09:46:20 PM

  • Fresh Fimker
  • *
  • Posts: 14
    • View Profile
Quote from: Dirk Diggler
(...)
If you want to get back the old UI the only way would be to copy back the contents of html folder from FIMK 0.3.3 to FIMK 0.4.0 [b
and[/b] set "nxt.apiResourceBase=html/ui" in nxt.properties.
(...)

Thanks it worked. Just needed to enable old UI and/or only use ctrl +F5 to get rid of old html from cache ;) Now need to try out new MOFO 4.1 too :)

kani #27 on: March 28, 2015, 10:57:25 PM

  • Senior Fimker
  • ***
  • Posts: 154
    • View Profile
nxt.apiServerEnforcePOST=false
Then try [link removed]

This suggestion might cause a local security risk if performed from a web browser.  The secret passphrase may be saved in browser history and/or cache.

NXT developers switched to POST in the 0.8.1e release with the following comments:
Quote
Support use of POST in addition to GET for all API and UI http requests.
To enforce use of POST only, for those requests that require the user
secretPhrase, the nxt.properties nxt.apiServerEnforcePOST and
nxt.uiServerEnforcePOST can be set (default is false for API, true for
UI). This way client developers can enforce that only POST requests are
used for handling sensitive data.

The default NRS browser UI has been changed to use POST only, and so have
the tools - admin.html, message.html, alias.html. This way the user
secretPhrase will no longer be cached in the browser memory.

Source: https://bitcointalk.org/index.php?topic=345619.msg5339924#msg5339924

If you have done this and are worried about the security risk, clearing your browser history and cache should eliminate the risk
« Last Edit: March 29, 2015, 12:29:00 AM by kani »
BitShares - Your share in the Decentralized Exchange

Dirk Diggler #28 on: March 29, 2015, 12:19:22 PM

  • FIMK Staff
  • *****
  • Posts: 486
    • View Profile
    • Krypto Fin ry
Is it a normal, that about all 5 minutes is a rollback?
I'm forging with a VPS Ubuntu.

Yes that's normal. It's the dynamism on the network that has always been there but was made more visual through recent upstream (NXT) changes. Don't worry about it.
FIMK Developer | GPG fingerprint: CEF2 7C39 43BE 6800 504E  71BC 7E87 A7B0 AC34 E2D5 | mofowallet.com | blog

OrgiOrg #29 on: March 30, 2015, 08:18:17 AM

  • Fresh Fimker
  • *
  • Posts: 31
    • View Profile
hello, after updating at 0.4.0 my FIMK doesn't start anymore  :-\

any ideas?

Code: [Select]
2015-03-30 03:24:59 FINE: Peer 167.160.164.21 version 0.4.0 returned error: {"ca
use":"java.io.IOException: java.util.concurrent.TimeoutException: Idle timeout e
xpired: 30000\/30000 ms","error":"Your peer is blacklisted"}, request was: {"pro
tocol":1,"requestType":"getCumulativeDifficulty"}, disconnecting
2015-03-30 03:34:33 FINE: Peer 167.160.164.21 version 0.4.0 returned error: {"ca
use":"java.io.IOException: java.util.concurrent.TimeoutException: Idle timeout e
xpired: 30000\/30000 ms","error":"Your peer is blacklisted"}, request was: {"sha
reAddress":true,"platform":"PC","protocol":1,"application":"FIMK","requestType":
"getInfo","nxtversion":"1.4.13","version":"0.4.0"}, disconnecting
2015-03-30 04:31:35 FINE: Will process a fork of 1 blocks
2015-03-30 04:31:35 FINE: Rollback from 450475 to 450474
2015-03-30 04:31:35 FINE: Switched to peer's fork
2015-03-30 04:36:08 FINE: Will process a fork of 1 blocks
2015-03-30 04:36:08 FINE: Rollback from 450480 to 450479
2015-03-30 04:36:08 FINE: Switched to peer's fork
2015-03-30 04:38:00 FINE: Will process a fork of 1 blocks
2015-03-30 04:38:00 FINE: Rollback from 450483 to 450482
2015-03-30 04:38:00 FINE: Switched to peer's fork
2015-03-30 05:04:46 FINE: Will process a fork of 1 blocks
2015-03-30 05:04:46 FINE: Rollback from 450514 to 450513
2015-03-30 05:04:46 FINE: Switched to peer's fork
2015-03-30 05:05:16 FINE: Will process a fork of 2 blocks
2015-03-30 05:05:16 FINE: Rollback from 450514 to 450513